Merchant and customer experience unavailable
Incident Report for Smile.io
Resolved
We have identified and resolved the issue around Smile unavailability and all systems are working as expected.
Posted over 1 year ago. Apr 04, 2018 - 18:02 EDT
Investigating
We are investigating an issue that is preventing account owners and customers from using Smile
Posted over 1 year ago. Apr 04, 2018 - 17:55 EDT