Delays in order processing and VIP tier calculations
Incident Report for Smile.io
Resolved
This incident has been resolved.
Posted May 20, 2022 - 12:01 EDT
Investigating
Points awarding for orders are delayed at the moment. We are currently investigating this issue.
Posted May 18, 2022 - 17:28 EDT
This incident affected: Smile Customer Experience.